понедельник, 29 ноября 2010 г.

Собираем Qt Creator с Qt 4.7.1

В предыдущих постах я написал, что Qt Creator 2.0.1 и 2.1 beta 2 не собираются с бинарниками из Qt Framework 4.7.1 под Windows. Как выяснилось, не собирается и Qt Creator 2.1 RC1, и не только под Windows, но и под Linux.

Я скачал исходники Qt 4.7.1 и просто собрал под MSVC 2008, используя вот такой config:
configure -opensource -debug-and-release -shared -platform win32-msvc2008 -developer-build -qt-sql-sqlite -plugin-sql-sqlite -webkit -script -declarative -qt-libtiff -nomake examples -nomake demos -no-qt3support -no-opengl -no-phonon -no-phonon-backend

Надо сказать, что все собралось, и Qt Creator 2.1 RC1 слинковался на ура.

UPD: Выяснилось, что качать/собирать Qt не обязательно. Проблема была вчера (30 ноября) зарегестрирована как QTBUG-15744 и решается копированием правильного файла зависимостей qt_webkit_version.pri в нужное место ($QTDIR/mkspecs/modules).

Комментариев нет:

Отправить комментарий